Use mathematical range syntax for dependencies

In dd84d53bbc the usage of dynamic
dependencies was removed because OSS Sonatype would not longer allow
them, i.e. the '1.2.+' notation, on release artifacts. But they allow
the mathematical range notation '(1.2,1.3]', therefore we use this now.
filetransferTypos
Florian Schmaus 8 years ago
parent add4ff5b5a
commit 31c53f094c
  1. 2
      smack-bosh/build.gradle
  2. 2
      smack-compression-jzlib/build.gradle
  3. 2
      smack-debug-slf4j/build.gradle
  4. 2
      smack-resolver-dnsjava/build.gradle
  5. 2
      smack-resolver-minidns/build.gradle

@ -4,5 +4,5 @@ This API is considered beta quality."""
dependencies {
compile project(':smack-core')
compile 'org.igniterealtime.jbosh:jbosh:0.8.0'
compile 'org.igniterealtime.jbosh:jbosh:(0.8,0.9]'
}

@ -4,5 +4,5 @@ Allow to compress the XMPP stream with help of jzlib."""
dependencies {
compile project(path: ':smack-core')
compile 'com.jcraft:jzlib:1.1.3'
compile 'com.jcraft:jzlib:(1.1,1.2]'
}

@ -5,6 +5,6 @@ Connect your favourite slf4j backend of choice to get output inside of it"""
dependencies {
compile project(':smack-core')
compile 'org.slf4j:slf4j-api:1.7.7'
compile 'org.slf4j:slf4j-api:(1.7,1.8]'
testCompile project(':smack-core').sourceSets.test.runtimeClasspath
}

@ -5,5 +5,5 @@ javax.naming API (e.g. Android)."""
dependencies {
compile project(path: ':smack-core')
compile 'dnsjava:dnsjava:2.1.6'
compile 'dnsjava:dnsjava:(2.1,2.2]'
}

@ -5,6 +5,6 @@ javax.naming API (e.g. Android)."""
dependencies {
compile project(path: ':smack-core')
compile 'de.measite.minidns:minidns:0.1.1'
compile 'de.measite.minidns:minidns:(0.1,0.2]'
compile "org.jxmpp:jxmpp-util-cache:$jxmppVersion"
}

Loading…
Cancel
Save